option 125 issue

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view

option 125 issue


I have isc dhcp appliance on my local environment and for mitel(VOIP  phones) to work .
I tried to assign the option 125 with value id:ipphone.mitel.com;sw_tftp=;call_srv=1..3.6.4;vlan=1;l2p=6;
but still i see the issue, when i search on google forums, few of them say that semicolon is not accepting and they tried with some hexadecimal concept but for me after updating the dhcp config I tried with syntax check command but it is not throwing any error 
[root@server1 ~]# cat dhcpdtest.conf
subnet netmask {
       option subnet-mask;
       option routers;
       option domain-name "test.com";
       option vivso " ipphone.mitel.com;sw_tftp=;call_srv=1..3.6.4;vlan=1;l2p=6 ;";
[root@server1 ~]# dhcpd -t -cf dhcpdtest.conf
Can anyone has idea about this? will the option 125 needs to be in hexadecimal format only to work or is it can be normal string ?
If it accepts only hexadecimal they why is the dhcpd syntax checker command is not throwing error? 

Thanks in advance

dhcp-users mailing list
[hidden email]